Key Rig - Vista 64 & Windows 7
Results 1 to 9 of 9

Thread: Key Rig - Vista 64 & Windows 7

  1. #1
    Jared is offline Tech Support, Community Mgr, Customer Advocate
    Join Date
    May 2008
    Location
    Irwindale, CA
    Posts
    16,488

    Default Key Rig - Vista 64 & Windows 7

    The KeyRig 25 & KeyRig 49 keyboards are plug and play on Windows Vista & Windows 7: http://www.m-audio.com/index.php?do=...ee81c346f15396

    The Key Rig virtual instrument software is not qualified or supported on Vista 64 or Windows 7; however, you can install the Key Rig virtual instrument software from the included CD; then download and install the Key Rig 1.1.0.4v6 updater. Once updated you will not need to certify Key Rig: http://www.m-audio.com/index.php?do=...drivers&f=1031

    * Use at your own risk, please do not contact M-Audio Tech Support for issues with the Key Rig virtual instrument software on Vista 64 or Windows 7.

  2. #2
    Join Date
    Jan 2010
    Posts
    3

    Default

    I am running vista 64 bit and my keyrig 49 does not plug and play. I am not prompted at all to alert the detection of a new device or install any drivers. I cannot install the software on the cd. It says "Your operating system is not compatable for use with the M-Audio Series II Media at this time" The update will not run, obviously because the software is not installed"

  3. #3
    Join Date
    Jan 2010
    Posts
    3

    Default

    I am upgrading to windows 7 shortly so I am more concerned about if that will work.

  4. #4
    Join Date
    Jan 2010
    Location
    PA, USA
    Posts
    5

    Default

    So I upgraded to Windows 7 64-bit, (from Vista 64) with a clean install, and had no previous problems running my KeyRig 49 with Reason 4.0. With this new setup, I get a 'Driver Software Installation' message saying "Device driver software was not successfully installed" and under that it says "USB Composite Device" installed properly but "KeyRig 49" did not. I have tried two different cables and all 4 USB ports (powered, on the comp itself) and nothing has worked. Any ideas? I know it's supposed to be plug and play but something isn't right. EDIT: Also tried running MIDI-OX and it didn't recognize it. the lights are on on the keyboard, but no signals are being sent.

    EDIT: MAJOR CORRECTION! WINDOWS 7 + KEYRIG DOES WORK. I will post a new thread about it with directions for everyone.

    CHECK OUT MY POST ABOUT IT HERE
    Last edited by robert.may; 01-10-2010 at 11:13 PM.
    HP Elitebook 8530w
    -Core2Duo T9400 @ 2.53Ghz
    -4GB RAM
    -Windows 7 Pro 64-bit

    -MBox 2
    -KeyRig 49

    Reason 4.0
    ProTools LE 8

  5. #5
    Join Date
    Jan 2010
    Posts
    3

    Default

    Thanks for the help. I've taken it back

  6. #6
    Join Date
    Jun 2010
    Posts
    1

    Default

    i just bought the KeyRig 49 with the included software. I bring it home only to see that it will not run with Win 7. In addition the first thing i read when I try to find help on the forum is an admin saying "please do not contact M-Audio Tech Support for issues with the Key Rig virtual instrument software on Vista 64 or Windows 7".

    I'm returning my KeyRig 49 to the shop NEVER to consider an M-audio product ever again. And hell yeah, I'm pissed off

  7. #7
    Join Date
    Jun 2010
    Posts
    1

    Default

    hauk i can understand you.


    i have bought the keyrig 49 and it will not work on vista 32 bit sp1 even though i have downloaded the drivers, reinstalled the program and then run the updater program exactly like specified in the OP. It worked for a day after that and now, today, its the same thing.

    whats wrong with this???

  8. #8

    Default

    Hi, i just purchased an M-Audio keyrig 49 (USED) and it came with the Ableton 6 lite CD but i don't have the Keyrig Virtual Instrument Cd or if there is supposed to be one. If anyone of you can help me with this problem as i cannot find any downloads for it.
    thank you.

  9. #9

    Default Windows 7 64 bit

    My new Keyrig49 arrived today. Plug and play was problem free, with the keyboard installed in seconds. I was prompted to download updated drivers...no problem.

    I installed Live Lite 6, and was taken to a web page that informed me I was able to upgrade to Live Lite 8 at no charge. So version 6 came off and version 8 went on without problem.

    I installed the Keyrig software, which informed me it would not run in "stand alone mode" because I don't have an ASIO compliant sound card. However everything was available and working as a plug-in in Mixcraft (and, I presume Live Lite) so who cares.

    Online registration of the Keyrig software didn't work, so I emailed support who directed me to this thread. I downloaded the upgrade and all is now well.

    I think this is an awesome piece of hardware for $100.

Similar Threads

  1. windows vista
    By billbru in forum USB Audio Series
    Replies: 1
    Last Post: 06-23-2010, 05:35 PM
  2. Replies: 13
    Last Post: 12-16-2009, 06:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •