Microtrack II dead - won't turn on
Results 1 to 5 of 5

Thread: Microtrack II dead - won't turn on

  1. #1
    Join Date
    Mar 2010

    Default Microtrack II dead - won't turn on

    My MicrotrackII is dead.

    Needless to say, I haven't changed anything with the device since I used it successfully last week.
    I have been using it for about a year. Now it doesn't even power on.

    When mot plugged into USB, pressing the power button does nothing.
    When plugged into USB, it say "Booting Firmware", but it says so forever,
    and no pressing of any keys has no effect; it does not appear as a USB storage
    in the computer.

    To make sure it is not a depleted battery, I let it plugged in overnight,
    then tried again. No change.

    I tried pressing and holding POWER+DEL, and POWER+REC, and POWER+MENU,
    as suggested across this forum, but none of that does anything.

    Using the "rescue firmware" is not possible: the device does not even appear
    to the computer, so there is no way to copy the firmware files over.

    Can someone knowingly say what the problem is please?
    How do I fix that?

  2. #2
    Join Date
    Mar 2010


    Forgot to add: this happens with different CF card, or no CF card at all - no difference.

  3. #3
    Join Date
    Mar 2010


    I took the CF card out of the non-functional MTII, copied the rescue files on it as per
    and put the CF card back into the MTII. Trying to boot with MENU+POWER pressed.
    Nothing happens; when I plug it into USB, says "Booting firmware" forever; i.e. same as before.

  4. #4
    Jared is offline Tech Support, Community Mgr, Customer Advocate
    Join Date
    May 2008
    Irwindale, CA


    I'm not sure exactly what's wrong, but if it's not booting and the reset procedures aren't working, something is malfunctioning.

  5. #5
    Join Date
    Mar 2010


    Yes, something is most probably malfunctioning, thank you very much.

Similar Threads

  1. BX5a LED does not turn on
    By hobolordx2 in forum Speakers, Headphones & Earphones
    Replies: 0
    Last Post: 08-04-2011, 04:30 PM
  2. Microtrack II Doesn't turn on with Sandisk Ultra CF 4 GB in.
    By Matthewspeardj in forum MicroTrack Series
    Replies: 2
    Last Post: 11-24-2010, 03:24 PM
  3. Should I turn off the FTP when I'm not using it?
    By yanis in forum USB Audio Series
    Replies: 4
    Last Post: 07-16-2010, 11:30 PM
  4. Dead Microtrack II ? RESOLVED
    By peekolo in forum MicroTrack Series
    Replies: 5
    Last Post: 05-08-2010, 11:11 AM
  5. Replies: 1
    Last Post: 07-20-2009, 09:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts