Asio driver stops working. (device not found)
Results 1 to 6 of 6

Thread: Asio driver stops working. (device not found)

  1. #1
    Join Date
    Jul 2008
    Posts
    1

    Default Asio driver stops working. (device not found)

    Hello M-Audio,

    This error has come across a few times now and i'm starting to worry cause i can't seem to fix it.
    Whenever i'm working on my songs, all of a sudden the Asio driver stops working and i get a dialog box
    telling me: "The needed sample rate (44100Hz) couldn't be set or is not supported by the ASIO driver. Please try another sample rate".
    Another error I get pretty frequently is "Not enough asio output channels available. at least 2 channels are needed."
    After that the soundcard stops working and i get "No M-Audio Firewire device was found connected to this PC."
    After reinstalling the drivers it goes all well for another 15mins.
    The pci firewire card is on IRQ 21 and is not shared with other cards.
    The brand and type of the card is: ICIDU AI-707903 USB 2.0 / Firewire PCI Card

    I hope you can help me with this problem.
    Last edited by Repoman; 07-18-2008 at 05:54 PM.
    Model: Dell Dimension 4600i
    OS: WinXP SP3
    Processor: Intel P4 3Ghz
    RAM: 1GB
    FireWire: Expansion card (VIA)
    M-Audio Devices & Driver Versions: Firewire 410 (latest driver)

  2. #2
    Join Date
    Jun 2008
    Posts
    625

  3. #3
    Join Date
    Jun 2009
    Posts
    1

    Default

    Hi!

    I have met the same problem nowadays (error message: The needed sample rate (44100Hz) couldn't be set or is not supported by the ASIO driver). I have Creative SB PCI 128 (CT4810) and the latest drivers available from Creative Official website. This issue at me is only present at ASIO DirectX Full Duplex and says the error message every time it accesses the sound device, ASIO Multimedia works fine. These are the ASIO drivers Cubase 3.X installs along with itself. I noticed that if I turn off input ports the error popup goes away, so there's something to mess around with the input. I took a look at the recording section of the ASIO DirectX Full Duplex configuration panel and saw, that the Audio Channels is set to 4, which is an incorrect value for the real number of input channels which is 2. I tried to click on it once, twice, but couldn't get to change the value to 2. So I started RegMon and found out where it stores these values.

    Solution
    They're under HKEY_LOCAL_MACHINE\SOFTWARE\ASIO\ASIO DirectX Full Duplex\Inputs\DS_0000 and HKEY_LOCAL_MACHINE\SOFTWARE\ASIO\ASIO DirectX Full Duplex\Inputs\DS_0001. At each section (DS_*) there's a REG_BINARY named Audio Channel and has a value 04. This represents the number of Input channels (4). Double-click on this record, it'll show the binary data editor of regedit. You would want to go to the left part of it, select the value 04 and overwrite it to 02. Do this for both DS_0000 and DS_0001 and the annyoing thing will go away.

    Alternatively, you can create a .reg file containing...
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\ASIO\ASIO DirectX Full Duplex\Inputs\DS_0000]
    "Audio Channel"=hex:02
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\ASIO\ASIO DirectX Full Duplex\Inputs\DS_0001]
    "Audio Channel"=hex:02
    ...and double-click on it to add to the registy.

    If channel settings are correct, please check other settings whether they match the actual preferences of your soundcard.

    Greets
    stringZ

  4. #4
    Join Date
    Oct 2008
    Location
    Sierra Madre, CA
    Posts
    11,806

    Default

    Thanks for the information, but wondering if this fix will work with the M-Audio ASIO driver.

  5. #5
    Join Date
    Jan 2010
    Posts
    1

    Default Does'nt Work

    Quote Originally Posted by stringZ View Post
    Hi!



    Solution
    They're under HKEY_LOCAL_MACHINE\SOFTWARE\ASIO\ASIO DirectX Full Duplex\Inputs\DS_0000 and HKEY_LOCAL_MACHINE\SOFTWARE\ASIO\ASIO DirectX Full Duplex\Inputs\DS_0001. At each section (DS_*) there's a REG_BINARY named Audio Channel and has a value 04. This represents the number of Input channels (4). Double-click on this record, it'll show the binary data editor of regedit. You would want to go to the left part of it, select the value 04 and overwrite it to 02. Do this for both DS_0000 and DS_0001 and the annyoing thing will go away.


    stringZ

    I dont see the ASIO DirectX Full Duplex thing under ASIO floder help please !

  6. #6
    Join Date
    Oct 2008
    Location
    Sierra Madre, CA
    Posts
    11,806

    Default

    tennisam,

    What exactly is the problem you are having and what M-Audio hardware do you have?

Similar Threads

  1. No ProFire 610 device could be found on PC
    By jayjay345 in forum FireWire Series
    Replies: 1
    Last Post: 06-16-2010, 10:56 AM
  2. Error: no ASIO drivers found.
    By Awesome1601 in forum Key Rig Virtual Instrument Software
    Replies: 1
    Last Post: 05-24-2010, 11:13 AM
  3. Fast Track PRO ASIO driver not working with USB MIDI keyboard
    By sour_42000 in forum USB Audio Series
    Replies: 4
    Last Post: 05-04-2010, 03:53 PM
  4. Replies: 1
    Last Post: 01-29-2010, 04:40 PM
  5. Replies: 1
    Last Post: 09-25-2009, 11:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •